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Autodesk Map 3D 2007 and ESRI ArcSDE 
Basics 
Many organizations, such as utilities, telecommunication providers, and government 
agencies, depend on geospatial data that is stored in a spatial database accessed by ESRI® 
ArcSDE™ software. Autodesk Map® 3D 2007 software enables organizations to expand 
access to ESRI ArcSDE data by letting other groups such as the engineering staff access 
data that was once accessible only to geographic information system (GIS) professionals 
using ESRI software. Autodesk Map 3D 2007 is designed to reduce bottlenecks and data 
management costs with powerful computer-aided design (CAD) tools that are familiar to 
many users in the organization. 

This paper shows how organizations can use Autodesk Map 3D 2007 to connect, read, edit, 
and save data stored in an ESRI ArcSDE spatial database environment. 
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Terminology 
When working with spatial databases, it is essential to understand the associated terminology 
and concepts. The following terms are used throughout this document.  

Data Store—In Feature Data Objects (FDO), a collection of feature classes contained in a 
single storage location. The data store consists of an integrated set of objects, which are 
modeled by classes or feature classes defined within one or more schemas. Data stores can 
be either file based, such as SDF, or a database, such as Oracle® Spatial.  

Drawing Objects—Objects that exist in a drawing file (DWG) or come from an attached 
drawing. Compare to features.  

FDO Provider—An implementation of the FDO API (application programming interface) that 
provides access to data in a particular data store, such as an Oracle or ArcSDE database, or 
to a file-based data store, such as SDF or SHP. 

Feature(s)—An abstraction of natural or man-made, real-world object. A spatial feature has 
one or more geometric properties. For example, a road feature might be represented by a 
line, and a hydrant might be represented by a point. In Autodesk Map 3D, features are 
accessed and added to maps using FDO via the Data Connect dialog. Compare to drawing 
objects. 

Feature Class—A schema element that describes a type of real-world object. It includes a 
class name and property definitions. Commonly used to refer to a set of features of a 
particular class, for example, the feature class “roads” or the feature class “hydrants.”  

Feature Data Objects (FDO)—An Autodesk® software standard and general-purpose API for 
accessing features and geospatial data regardless of the underlying data store. 

Feature Layer—A layer in Autodesk Map 3D software’s Display Manager containing features 
from a feature source such as SDF, ESRI SHP, or ArcSDE.  

Feature Source—In Autodesk Map 3D, a feature source is any source of feature data that 
has been connected by means of FDO.  

Schema—The definition of multiple feature classes and the relationships between them. A 
schema is a logical description of the data types used to model real-world objects. It does not 
reference the actual data instances (a particular road or parcel). Rather, it is metadata.  

Service (also Oracle Service)—An executable process installed in the Microsoft® Windows® 
registry and administered by the operating system. Once a service is created and started, it 
can run even when no user is logged on to the computer. 

Transaction—A unit of interaction with a database management system or similar system 
that is treated in a coherent and reliable way independent of other transactions. A single 
transaction might require several queries, each reading and/or writing information in the 
database. 

Creating a Connection to ESRI ArcSDE 
Before you can use Autodesk Map 3D 2007 to create and edit ESRI ArcSDE data, you must 
establish a connection to the ArcSDE server. The first step is to ensure that you have the 
proper files installed on the machine where Autodesk Map 3D 2007 resides. Note that it is 
your responsibility to ensure that you have the necessary license rights to use ArcSDE 
software as described herein. 
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Step 1: Confirm ArcSDE Files and Directory Locations 
1. Navigate to C:\Program Files\Autodesk Map 3D 2007\FDO\bin and make sure the 

following files are installed:  

• ArcSDEMessage.dll 

• ArcSDEProvider.dll 

• MergeModuleCA.dll  

2. Running FDO Provider for ArcSDE requires three dynamically linked libraries (DLLs), 
sde91.dll, sg91.dll, and pe91.dll. In addition, you must ensure that the PATH 
environment variable references the local folder containing these DLLs or place the 
DLLs in C:\Program Files\Autodesk Map 3D 2007\FDO\bin. The absence of this 
configuration may cause the following exception message: “The ArcSDE runtime was 
not found.” 

 

 . 

Step 2: Connect Autodesk Map 3D to ArcSDE  
Once you have confirmed that you have the correct files installed, the next step is to use 
Autodesk Map 3D to connect to ESRI ArcSDE. 

1. Start Autodesk Map 3D 2007, and open the drawing you want to use with ArcSDE. 

2. In Display Manager, click Data and then select Add Data. 
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3. In the Data Connect dialog box, under Feature Sources, choose ArcSDE and specify 
the following to connect to ArcSDE: 

• Enter a connection name. This is a user defined connection name. 

• Enter the server name. This is the server name or server’s IP address. 

• Enter Instance to Use. Enter the ESRI ArcSDE server TCP/IP port number and 
protocol, for example, 5151/tcp. 

• Enter the user name and password. 

• Click the down arrow under Data Store and select the data store (Default 
Datastore in this example). 

• Optionally, click the down arrow under Version and select a version of the 
database.  
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4. Click the Connect button. If the connection is successful, you see a list of feature 
classes. 

 
Note: To save connection information for future projects, save the DWG file as a drawing 
template file (DWT). 

Basic Usage 
Autodesk Map 3D users can utilize spatial data accessed through ESRI ArcSDE in a variety 
of ways. In many instances, Autodesk Map 3D users need only to access and view spatial 
information for reference purposes when starting a new design project such as a highway or 
subdivision. In other cases, users can aid in the creation and maintenance of spatial 
information by directly editing and creating new information in the data store accessed 
through ArcSDE. In the case of a new infrastructure project, the engineer can design and 
populate the organization’s spatial database within the same application, streamlining 
workflow and enabling other users in the organization to instantly use this new information. 
The following scenario shows how you can use Autodesk Map 3D 2007 software’s precision 
CAD-based editing tools to directly access, edit, manage, and create data in an ESRI 
ArcSDE environment. 

Query Data into a Map 
Once you have connected to the ArcSDE server, you can query data directly into Autodesk 
Map 3D 2007. 

1. In the Data Connect dialog box, select the feature classes that you want to query into 
your drawing project 
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2. Click Add to Map.  

The Feature Source Query dialog box shows the feature classes you selected. 

 
Autodesk Map 3D provides the ability to add query conditions to filter data based on location 
and properties, and enables you to define custom SQL where clauses. 
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3. Once the query conditions have been specified, click OK to import the data into 
your drawing project. 

 

 

 

When you query data from an external data store into Autodesk Map 3D 2007, the feature 
class or classes you queried are displayed in the Display Manager. Autodesk Map 3D also 
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assigns a default stylization to the features. To change the stylization of a feature class, use 
the Display Manager tools. 

Stylize Data 
Using the Display Manager, you can stylize the data to highlight specific features or create 
thematic maps for analysis.  

 

Note: Point features by default are displayed using a square symbol. In the Display Manager, 
you can stylize points with user-defined symbols. For example, you can represent objects, 
such as manholes, with a symbol or graphic created as an AutoCAD® block.  

Edit Data 
Using the precision editing tools in Autodesk Map 3D, you can quickly and easily edit the 
queried data, including geometry and attribute information. 

Step 1: Check out Features for Edit 

1. From the Edit menu, choose Check-Out. 

2. When prompted, select the feature you want to edit and press Enter. 

Checking out a feature makes it available to edit (grips are enabled). The feature 
you selected has been checked out and locked within the data store. You can 
now edit the geometry using the grips or by right-clicking to access editing 
commands. You can also edit attribute information. 
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3. To edit a feature’s attribute values, launch the Data Grid by clicking the Grid 

icon on the Display Manager Tool Strip. 

 
4. In the Data Grid you can edit attribute values. 

 
Note: When you edit feature data in the Data Grid, the corresponding geometry is checked 
out and locked if possible. You must check in the geometry when you are finished editing. 
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Step 2: Check in Features to Save Edits 

Once you have finished editing either geometry, attribute values, or both, check the 
feature in to save your changes and additions to the feature source, releasing any 
locks.  

1. Select the features to check in using one of the following methods: 

• Click a feature or features. 

• From the Edit menu, choose Select Check-Out Features. 

• Right-click the feature layer in the Display Manager, and choose Select 
Checked-Out. 

2. From the Edit menu, choose Check-In. 

Note: If you have Update Edits Automatically enabled (default setting), the edits are 
written back to the data store as you edit. Checking in a feature in this scenario 
simply takes you out of an editing mode for that feature. When working in a relational 
database environment, it is advisable to disable Update Edits Automatically. For 
more information, refer to the Autodesk Map 3D help.  

Step 3: Extract Feature Geometry 

To use full CAD editing tools on features, Autodesk Map 3D users extract the 
geometry from the feature to create a drawing object, modify the drawing object using 
CAD tools, and then update the feature’s geometry.  

1. Check out the feature (see step 1 above). 

2. From the Modify menu, choose Advanced Feature Editing>Extract Geometry 
from Feature (Alternately, right-click the feature, and choose Extract 
Geometry from Feature). 

You can now use the full suite of Autodesk Map 3D CAD editing tools to edit the 
drawing object.  

Step 4: Update Feature Geometry 

When edits have been completed, update the feature’s geometry from the drawing 
object.  

1. Right-click the feature to be merged with a drawing object. Choose Update 
Feature from Geometry. 

2. When prompted, select the drawing object to merge. Press Enter. 

3. When prompted to erase the drawing object, do one of the following: 

• Click Yes to erase the original drawing object. 

• Click No to keep the drawing object in the drawing. 

Note: Keep the object if you plan to use it to create other features. You can 
store drawing objects on an AutoCAD layer and turn off visibility of the layer. 

4. Check in the edited feature. 

Work Offline  
Autodesk Map 3D 2007 provides functionality that can be useful for workers in the field or 
anyone who needs to work with data that resides in an RDBMS (relational database 
management system) data store (ArcSDE, Oracle, MySQL, and so forth) in a disconnected or 
offline state. To put it simply, Autodesk Map 3D enables you to work with a local copy of your 
RDBMS data and commit changes when you return to an online state. 
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1. Ensure that you are working in the Autodesk Map 3D Geospatial workspace. 

 
2. From the Edit menu, and clear the Update Edits Automatically check box. 

 
3. Check out the features you plan to use. (See Step 1 above under Edit Data.) 

4. On the status bar, click the Online/Offline toggle. 

  
You can now disconnect from your network and update or edit the feature(s) you checked out 
in a remote setting. Features that you checked out are now locked in the RDBMS. When you 
have completed your edits and are reconnected to the network, you can check your changes 
in to the feature source, releasing the locks. 

5. On the status bar, click the Offline/Online toggle. 

 
6. Check the feature(s) in. 

Create New Geometry 
In addition to editing existing data, you can use Autodesk Map 3D to create new geometry.  

There are two ways to create new features:  

• Use one of the feature creation commands to create a new feature. New features can 
be one of the following: Point, MultiPoint, LineString, MultiLineString, Polygon, or 
MultiPolygon.  

If the provider supports curves, the arc option is available in the LineString, 
MultiLineString, Polygon, and MultiPolygon creation commands. 

• Create a new feature from a drawing object’s geometry. Using standard CAD drawing 
tools such as point, line, and polyline, you can create new entities.  

Using Feature Creation Commands 

The following procedures assume that you are creating LineString or MultiLineString features. 
Similar procedures are used for point, multipoint, polygon, and multipolygon features. For 
more information, refer to the Autodesk Map 3D help. 

1. In Display Manager, right-click the feature layer for the new feature. Do one 
of the following: 

• Click Create New LineString feature_name. 

• Click Create New MultiLineString feature_name. 

Where feature_name is the name of the LineString or MultiLineString 
feature layer. 
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2. When prompted, specify the location for the new LineString or 
MultiLineString feature.  

3. Use the command line or right-click to complete the new feature. 

For more information, see MAPLINESTRINGCREATE and 
MAPMULTILINESTRINGCREATE in the Autodesk Map 3D help. 

4. Press Enter to complete the operation. 

The new feature is added to the data grid. To add information to the grid, see 
Editing Features using the Data Grid in the Autodesk Map 3D help. 

5. Check the new features in. 

Creating a New Feature from a Drawing Object  

To create a new feature from geometry: 

1. In Display Manager, right-click the feature layer. Choose New Feature from 
Geometry. 

2. When prompted, select the object or objects to convert to features. Press 
Enter. 

All selected objects are converted into a single feature. To create multiple 
features, perform this operation on one object at a time. When prompted, 
select the feature you want to edit and press Enter. 

3. When prompted to erase the drawing object, do one of the following:  

• Click Yes to erase the original drawing object. 

• Click No to keep the drawing object in the drawing. 

Note: Keep the object if you plan to use it to create other features. You can 
store drawing objects on a layer and turn off visibility of the layer. 

4. Check the new features in. 

Working with Long Transactions and Versions 
Often, several departments in an organization use enterprise spatial databases, such as 
ArcSDE and Oracle. This interdepartmental use of spatial data creates challenges when it 
comes to managing that data. As a result, enterprise databases must provide the ability for 
multiple concurrent users to create and edit the same data without creating duplicates or 
multiple copies of the original data. With spatial database access in Autodesk Map 3D 2007, 
a true multiuser editing environment is available to users of enterprise spatial databases. 
Before illustrating how Autodesk Map 3D supports a multiuser editing environment, it is useful 
to introduce some specific terminology. 

Every edit or change to data stored in a database is a transaction. There are two types of 
transactions: 

 Short transactions—Changes made to data usually completed within a matter of 
seconds and within a single session; normally used for ordinary maintenance of the 
database. 

 Long transactions—Changes made to data over several sessions; normally used for 
larger projects, such as a major equipment upgrade or extension to a service network. 
The data may change many times before it is considered permanent, and the time 
required before committing the changes may be several hours to several months. 

Autodesk Map 3D 2007 supports long transactions. Versioning is a type of long transaction. 
Simply stated, versioning is a method by which changes to a multiuser database are 
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recorded and managed by creating a “version” or alternate view of the database without 
duplicating the original data. 

Using the versioning features of Autodesk Map 3D 2007, designers and analysts can create 
and store more than one scenario in the database. This is particularly useful when working 
with designed versus as-built information or for creating what-if scenarios during the design 
phase of a project. 

Create a Version 
All version-enabled databases accessed through ESRI ArcSDE contain a default version, 
which is the original published view of the database. This original parent version is the root of 
a version tree. Successive versions are children of the default version. 

Note: A new version is dependent on an existing parent version. By default, ArcSDE tables 
are not version enabled. To use versioning in ArcSDE, use ArcSDE tools to enable 
versioning. When a table is not version enabled, edits you make to that table appear in all 
versions, regardless of which version is active at the time of editing. 

1. To create a new version, in the Map Explorer, click the connection name and then 
click Tools>Set and Manage Versions. 

 

2. The Versions dialog box appears. This is where versions are managed. 

 

 

3. To create a new version, click Add. Then select one of the following: 
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• New Version. This creates a sibling version. 

• New Child Version. This creates a child version. 

4. Enter a name for the new version. Click OK. 

 
5. Once you have created a version, you must activate it. Reopen the Versions dialog 

box (Tools>Set and Manage Versions). Note that the new version lies beneath the 
default or parent version. Select the version, and choose Active. 

 
6. The icon next to the active version is highlighted in green. Click OK. 
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7. You can now use Autodesk Map 3D software’s data creation and editing tools to 

create and modify versioned data. Use the same procedure for saving edits to the 
data store for versioned and nonversioned tables. See “Edit Data” earlier in this 
document. 

One of the benefits of versioning is that you can quickly compare different views of the data, 
such as a series of proposed road designs. In Autodesk Map 3D you simply switch between 
the different versions.  

8. In Map Explorer, from the Tools menu, choose Set and Manage Versions. Select the 
version and choose Active. Click OK to close the dialog box.  

 
Autodesk Map 3D requeries the data store and displays the versioned view of the data. 

Commit or Discard a Version 
When the project is finished, or at the end of an editing session, you can discard (roll back) or 
commit (merge) edited features to the parent version, and reconcile any conflicts. Before 
discarding or committing versions to the parent, make sure the parent is active. 
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• To commit or discard a version: In Map Explorer, from the Tools menu, choose Set 
and Manage Versions. Select the version and choose Merge or Rollback. Click OK to 
close the dialog box. 

 

Working with the OSGeo FDO Provider for ArcSDE 
Autodesk Map 3D software’s Feature Data Objects (FDO) uses a provider to connect to 
different data stores. When working with the Autodesk FDO Provider for ArcSDE, you must 
follow specific parameters as well as understand some limitations. 

Requirements 
Autodesk Map 3D 2007 requires the following software when connecting to ArcSDE: 

 ESRI ArcSDE 9.1 Server on Oracle Database 9i, release 9.2.0.6 

Data can be stored in binary large object (BLOB) column type or SDO_Geometry 
column type. 

 ESRI ArcSDE 9.1 Server on Microsoft SQL Server 2000 (SP4) 

Dynamic Link Libraries  
The following ESRI files must be installed on the same machine as Autodesk Map 3D 2007: 

 Pe91.dll 

 Sde91.dll 

 Sg91.dll 

FDO Provider for ArcSDE Limitations 
The FDO Provider for ArcSDE is based on a subset of the ArcSDE API. This subset does not 
include the following: 

• Raster functionality 

• Native ArcSDE metadata 

• Annotation data, with the exception of the ANNO_TEXT column 
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ArcSDE Limitations  
FDO Provider for ArcSDE must abide by limitations of the ArcSDE technology to which it 
connects. This section discusses these limitations in relation to ArcObjects API and ArcGIS® 
Server API. 

The ArcSDE API does not support the following advanced functionality found in the 
ArcObjects API and the newer ArcGIS Server API: 

• Advanced geometries, such as Bezier curves and ellipses 

• Relationships 

• Topology 

• Networks 

• Analysis 

• Linear referencing 

 

Tips and Suggestions 
Use the following tips and suggestions when working with Autodesk Map 3D 2007 and 
ArcSDE. 

Schema and Feature Classes—The current release of the OSGeo™ FDO Provider for 
ArcSDE does not support creation of new schemas or feature classes within ArcSDE. Use 
ArcSDE tools to create new schemas and feature classes. 

Coordinate Systems—If you have a coordinate system assigned to the current drawing, 
avoid queries that retrieve features from more than one coordinate system within one feature 
source. If a single feature source query retrieves features from more than one coordinate 
system, the objects may appear in the wrong location in your drawing. If the features are in 
different feature sources, or are all in the same coordinate system, this is not an issue. 

Measure (m) Coordinate Values—You cannot edit an ArcSDE object that has measure (m) 
values in the coordinates. 

Locks—By default, ArcSDE tables are not lock enabled. To use locking in ArcSDE, use 
ArcSDE tools to enable locking. When locking is not enabled, users can add objects to the 
edit set, but they are not locked in the feature source. Multiple users can check out the same 
object. One user’s edits may be overwritten by those of another user. 

Documentation—In-depth documentation can be found in the Autodesk FDO Developer’s 
Guide available in the Autodesk Developer Center at www.autodesk.com/developer. 
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