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TIPS earthVision®9.1 Windows® Installation Guide 

December 2015 
 
supported: XP32/7x32/7x64; maybe: Vistas®/10; not:  XP64/8/8.1 

 
TIPS users must have KeyClient7.X or higher installed.  Open Control Panel, view by large icons and look for 
KeyAccess.  If missing or less than version 7, download k2client32 or 64 from 
www.tips.osmre.gov/Software/Downloads.shtml; install.  Change server name to that in the License Information 
Sheet.  Restart if asked. 
 

Needed: 
 License Information Sheet (attached to earthVision (EV) Distribution Letter) 
 EV9.1 64(or 32) MKS zipped file from Sharefile or EV9.1 "Microsoft Windows” DVD 
 “ev_companion_files.exe” from www.tips.osmre.gov/Software/Downloads.shtml or 2011 

EV8.1 Companion CD 
 

Software Check:  Login as Administrator to see if EV and related software are installed: Control 
Panel -> Programs and Features (or Add/Remove Programs).  If ANY of the following:  earthVision 
8.X or 9.0; ev9_x64, earthvision75 bat; XWin32; MKS or PTC or Nutcracker Platform Components 
are installed, skip to Upgrading on page 4; otherwise continue with New Installation. 

 
New Installation 

A. Login with Administrative rights and identify Windows version and graphics card: 

Windows version (Right-click computer or “my computer” then “properties”): 
XP32:____Win7x32:____Win7x64: _____ Other: __________ 

Graphics Card (Right-click Desktop->Screen Resolution->Advanced (different on XP) 
NVIDIA Model ________ ATI Model ________ Other Make/Model __________ 

B. Go to Control Panel -> System -> Advanced settings -> Environment Variables and add 
the 2 license variables provided in the License Information Sheet. 

C. Install EV: IF USING DOWNLOAD: Unzip the 64 or 32 EV9.1 MKS zipped file 
downloaded from Sharefile; open EV91_win64_MKS_1nov2015 or 
EV91_win32_MKS_1nov2015 folder.  IF USING DVD:  Open   
EV91_win64_MKS_1nov2015 or EV91_win32_MKS_1nov2015 folder. Run setup.exe 
and wait while several packages are installed.  Take all defaults but don’t restart, finish. 

http://www.tips.osmre.gov/Software/Downloads.shtml
http://www.tips.osmre.gov/Software/Downloads.shtml
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D. Companion files:  IF USING DOWNLOAD: Double-click “ev_companion_files.exe” 
to open the WinZip self-extractor.  Unzip to C:\TEMP with password from License 
Information Sheet. Navigate to C:\TEMP\XWIN.  IF USING CD:  Open XWIN folder. 

E. Run X-Win32_2010.msi** accept license, take all defaults, finish. 

** An "Error 27519" message is harmless; [Ignore] or [Skip] and continue. 

F. Register XWin32 with MKS/PTC.  In the same XWIN folder: 

1. 32-bit Windows, right-mouse-click 32_variable.reg, select “Merge,” “Yes” and “Ok” 

2. 64-bit Windows, right-mouse-click 64_variable.reg, select “Merge,” “Yes” and “Ok” 

G. Create XWin32 environment.  In the same XWIN folder: 

1. NVIDIA graphics, open nvidia_graphics folder and double-click 
nvidia_graphics.bat*** 

*** If a DOS window pops up asking if you want to overwrite files; type A to confirm. 

2. ATI or other graphics, open other_graphics folder and double-click 
other_graphics.bat*** 

*** If a DOS window pops up asking if you want to overwrite files; type A to confirm. 

H. Restart computer and login as a regular user 

I. Recreate the XWin32 environment by repeating Step H. 

J. Test license settings: From EV Main Menu, select Visualization then 3D Viewer. If the 
Viewer and file selection don’t open after a bit, double-check Step 1. If settings are good, 
there may be Firewall issues. Contact us.  You should get a firewall alert.  It’s harmless - 
click “cancel” and back out of the Viewer.  The alert won’t appear again.  
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K. Now test XWin32: Open EV Main Menu->Visualization->Base and Contour Maps. A 

dialog box should open after a bit. If it doesn’t, repeat once or twice.  When XWin first 
starts, expect another one-time-only firewall alert: click “Cancel” and move on. 

L. If the dialog box never appears, the system may be incompatible with XWin32 – call 
Mike for diagnosis and workarounds. 

M. EV9.1 is now installed. 

N. For shared computers, each user must repeat Step H. 

O. See Appendix A for important/recommended settings. 
  

Upgrading from earthVision 8.0/8.1/8.2/9.0 

1. Login with local Administrator rights – refer to Software Check on page 1. 

2. Control Panel->Add/Remove Programs (XP) or Programs and Features (Win7); remove 
any version of earthVision 8 or 9.0.  If you can’t remove EV, see Appendix B. 

4. Click MKS (or PTC) Platform Components, if present. Look at bottom of window for 
version (or "Version" column if in detailed view.)  If version 9.6, keep it; if not 9.6, remove 
it.  If you can’t remove MKS, see Appendix B.
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Install EV: IF USING DOWNLOAD: Unzip the 64 or 32 EV9.1 MKS zipped file 
downloaded from Sharefile; open EV91_win64_MKS_1nov2015 or 
EV91_win32_MKS_1nov2015 folder.  IF USING DVD:  Open   
EV91_win64_MKS_1nov2015 or EV91_win32_MKS_1nov2015 folder. Run setup.exe 
and wait while several packages are installed.  Take defaults, finish and restart computer. 

5. Xwin32 is required for a complete installation. If you didn’t find XWin32 during Software 
Check (page 1), go to New Installation and complete steps D through I. 

6. Test license settings: From EV Main Menu, select Visualization then 3D Viewer. If the 
Viewer and file selection don’t open after a bit, double-check Step 1. If settings are good, 
there may be Firewall issues. Contact us.  You should get a firewall alert.  It’s harmless - 
click “cancel” and back out of the Viewer.  The alert won’t appear again. 

7. EV9.1 is now installed.  See Appendix A for important/recommended settings. 

8. These instructions are specifically for TIPS users.  The EV Site_Admin_Guide contains 
non-TIPS information that could be confusing; Appendix B of these instructions are from 
the guide and do apply to TIPS installations. 

 
Any issues or questions should be directed to:  Mike Dunn (mldunn@osmre.gov) 
(412)-937-2910 or Kristin Brown (kbrown2@osmre.gov) (303)-293-5048 

 

The TIPS’ website sometimes gets updated; every now and then, check the earthVision 
and download pages for patches, updates, and new features 

NOTE #1: Digitizing tablets are no longer supported.  Contact us if this is unacceptable. 
 
NOTE #2: Direct printing to some newer printers isn’t supported. Workaround: install a 
PDF printer; print to a file, open the file in a PDF viewer, then print. 

  

mailto:mldunn@osmre.gov
mailto:kbrown2@osmre.gov
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Appendix A – Recommended Performance and Desktop Settings 

 

PERFORMANCE 
 
Default Windows Vista and 7 settings aren’t optimized for high-end technical software.  An Administrator needs 
to make the following change: 
 
Open Control Panel -> System and Security -> System (Admin login and password needed) 
Under Advanced -> Settings and Adjust Visual Effects for best performance:  
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The “best performance” setting disables Windows Aero themes.  earthVision works best with 
Aero themes so re-enable your preference. 
 
As a regular user, right-mouse-click the Desktop, pick the Personalize option, then pick any one 
of the Aero themes.  Back out – save theme if you want – the aero effects are re-enabled but “best 
performance” is unaffected. 

 
Every week or two, recheck the performance settings.  IT departments and policies have a bad 
habit of putting everything back to the Window’s defaults. 
 
 

Show ALL Files and Extensions 
 

File extensions are hidden by default in Windows.  Because Windows’ “idea” of Type can’t be 
trusted, showing extensions helps you use the right files for all software.  Example:  A folder may 
have several files with the same name: 
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You can’t tell what these files are just from their names.  “Type” is often associated with the 
wrong program.  Not only is this confusing but it’s easy to delete the wrong files.  To show file 
extensions, click on My Computer to get a window that looks like this: 
 
Under the Organize dropdown Menu, choose Layout and turn on the Menu Bar 

Then click the Tools dropdown menu and select Folder Options. 
 

Select the View tab and under Advanced Settings, check:  
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Show Hidden Files, Folders and Drives then uncheck Hide Empty Drives in the Computer 
folder and Hide extensions for known file types and Hide protected operating system files 
(answer “yes” when Windows prompts). 
 
Click OK and now you can see all extensions. 
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Appendix B – Installation Problems 
(From Pages 23 through 25 of Dynamic Graphics EV Windows Install Guide) 

 

Errors During Installation 

An EarthVision installation will install the EarthVision software and, when the “mks” version is 
being loaded, the MKS Toolkit as well. Problems can occur in either of these steps. 
 

EarthVision Installation Problems 

The most common problems with the EarthVision installation is lack of disk space.  If this 
occurs, an error message will appear and the installation must be canceled. More disk space can 
be freed, the Trash Emptied on a particular disk, or another disk may be selected. When more 
space is available, the installation may be re-started. 
 

MKS Installation Problems 

False Error Message 

During the installation of the MKS software, an icon may appear on the Task Bar and all 
installation activity stops. Click on the icon and the message reports an installation error. Click 
“OK” in this box. Another box appears saying that MKS has suffered a Fatal Error upon 
installation. Normally this message is not correct and MKS has installed properly. EarthVision 
will continue automatically to install. Continue the installation process and verify that 
EarthVision is working. 
 

General Error Messages 

For most other MKS errors where MKS is not successfully installed, do the following: 
 

 Use the Add/Remove Programs function to remove any MKS or NuTCRACKER 
application. 

 
 Remove the “DataFocus” key from the registry: 

1. Open regedt32: 
Start -> Run -> regedt32 

 
2. Go to: 

HKEY_LOCAL_MACHINE\SOFTWARE\ 
 

Select the DataFocus key. 
 

Delete the DataFocus key by: 
Edit -> Delete 
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NOTE: Of course caution should be exercised here. We are trying to get rid of all the DataFocus 
entries but nothing else. 

 
 In extreme cases, it may even be necessary to remove the NUTROOT directory 

manually (usually C:\NUTROOT) after MKS 7.x has been uninstalled. 
 
 Reboot and try to re-install EarthVision. 

 

File Sharing Problems 

One class of MKS installation errors simply reports a Fatal Installation Error but does not install 
the MKS software. This can be due to the fact that MKS requires that the “File and Printer 
Sharing” service be turned on. To check this, please do the following: 
 
Start -> Settings -> Control Panel -> Network & Dial-up Connections -> Local Area Connection 
 
On the General tab, select Properties and look for the setting of: 
 

File and Printer Sharing for Microsoft Networks 
 
This service should be checked. If it is not, check it and reboot. 
 

Administrator Privileges 
 
Windows allows other users to have some or all privileges normally reserved for administrator. 
Unfortunately, these accounts often do not have full administrator privileges and this can provoke 
an error in the MKS installation. 
 
This type of failure to install MKS usually only provides a SEVERE error message stating that 
the installation could not be completed.. If this occurs, you should re-do the installation as the 
actual “administrator” account. 
 

Uninstallation Problems 
 
From time to time, the removing of EarthVision from a computer can encounter problems. 
Typically, the software is removed but it still exists on the Add/Remove Programs menu and 
new software will not install, complaining that the previous version is still installed. When this 
occurs, two things are required: 
 

A. Delete the “Dynamic Graphics\” folder (often in C:\Program Files\Dynamic Graphics\). 
B. Remove a key from the registry. Here are instructions for this removal: 
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Start up the registry editor: Start -> Run -> regedit 

 
Navigate to: 
 
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall 
 
From the table below, note the GUID of the previous version.  In regedit, find and select the 
key with that GUID.  Delete the key: Edit and Delete. 
 
Product Version Bit GUID 
EarthVision 8.0 32/64-bit {1B0999A5-F741-47E7-98BD-B245B5762D22} 
EarthVision 8.1 32/64-bit {F4848228-0B28-4594-A63D-B9F6C3D54347} 
EarthVision 8.2 32-bit {31B44257-DF75-4DBA-A616-53203C5299F0} 
EarthVision 8.2 64-bit {807575B6-268F-4C5D-B543-7825E6389FDF} 
EarthVision 9 32-bit {C16F6ED0-0827-4354-83EC-263B510E9894} 
EarthVision 9 64-bit {FC7F9E98-E6FC-4406-BF53-A47A551E0296} 
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