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earthVision®9.1 MSY'S Installation - Required for Classroom Training

(Win7x64-bit instructions, substitute 32-bit if needed)
. Login with Administrative rights.

. Go to Control Panel -> System -> Advanced settings -> Environment Variables and
add the 2 license variables provided in the License Information Sheet.

. Control Panel->Add/Remove Programs (XP) or Programs and Features (Win7); remove
any version of earthVision 8 or 9.0 and any version of PTC MKS Toolkit NutCracker
Platform Components. Restart computer

. Go to http://strawberryperl.com/ download and install the recommended 64-bit version.

. Open EV 9.1 Windows DVD, open MSYS/ev91l win64MSYS_1nov2015 and run
setup.exe, take all defaults. Finish and restart.

. Log in and confirm MSYS version: Open EV Main Menu -> Visualization; Base and
Contour maps should be grayed-out. If not grayed-out, you’ll have to repeat step C
then reinstall EV9.1 MSYS.

. Test license settings: From EV Main Menu, open the 3D Viewer. If the dialog box
doesn’t open after a bit, double-check Step B. If settings are good, you should get a
firewall alert. It’s harmless - click “cancel” and back out of the Viewer. The alert
won’t appear again.

,

@ Windows Firewall has blocked some features of this program

=)

Windows Firewall has blocked some features of evviewn.exe on all public and private netwarks.

Name: yviewn. exel
Publisher: Unknown

Path: C:'\program files\dynamic graphics
\evad1_x64'binc4\evviewn exe

Allow evviewn.exe to communicate on these networks:
Private networks, such as my home or work network

[] Public networks, such as those in airports and coffee shops (not recommended
because these networks often have litte or no security)

What are the risks of allowing a program through a firewall?

@]Ellow access .



http://strawberryperl.com/
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H. EV9.1 MSYS is now installed. See Appendix A for important/recommended settings.

These instructions are specifically for TIPS users. The EV Site_ Admin_Guide contains
non-TIPS information that could be confusing; Appendix B of these instructions are
from the guide and do apply to TIPS installations.

Any issues or questions should be directed to: Mike Dunn
(mldunn@osmre.gov) (412)-937-2910 or Kristin Brown
(kbrown2@osmre.gov) (303)-293-5048

The TIPS’ website sometimes gets updated; every now and then, check the
earthVision and download pages for patches, updates, and new features

NOTE #1: Digitizing tablets are no longer supported. Contact us if this is unacceptable.

NOTE #2: Direct printing to some newer printers isn’'t supported. Workaround:
install a PDF printer; print to a file, open the file in a PDF viewer, then print.


mailto:mldunn@osmre.gov
mailto:kbrown2@osmre.gov
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Appendix A - Recommended Performance and Desktop Settings

PERFORMANCE

Default Windows Vista and 7 settings aren’t optimized for high-end technical software.
An Administrator needs to make the following change:

Open Control Panel -> System and Security -> System (Admin login and password
needed) Under Advanced -> Settings and Adjust Visual Effects for best performance:

@ HMouseToggle

Bison Connect

E FileZilla

@ Microsoft Word 2010

Adobe Reader 31

&

204 Wicrosoft Excel 2010

g Google Earth Pro
[l ﬂ Motepad ++
EW hain henu

~j Motepad

2

b, AutaCAD Map 30 3015

Agizsoft PhotoScan Professional
(64 bit)

@ SketchUp 2016

. PhotoModeler Scanner [64-bit]

@ ShareFile Desktop
Q Archdap 10.3.1

Calculator

Raster Design 2015 on Autodesk ,

L

®

v Control Panel » All Control Panel Items » Systemn

~ [ 42 ][ Search Controi Pan

File Edit ‘View Tools

?p
Control Panel Home

) Device Manager

Remote settings

System protection

) Advanced system settings

Open
Manage

FileLocator Lite..,

Map netwaork drive...

Disconnect network drive.,

Shaw on Desktop

Rename

Properties

1 - right-mouse-click *Computer™

2 - select "Properties”

3 - select "Advanced system settings

4 - select Performance "Settings"

5 - under "Wisual Effects,” select

“Adjust for best performance™
oK

3

then close System Properties window

-

HMow have each user log in,
right click on his/her Desktop background,
select "Personalize” and select an "Aero"
theme

View basic information about your computer

Windows edition
Windows 7 Enterprice

Copyright © 2009 Microsoft Corporation. All rights reserved,

System Properties B3 Performance Options [=]
W
Computer Name | Hardwars | Advanced | System Pratection | F\emntel visual EffectsMy advanced | Data Execution Prevention ‘
*ou must be lagged on a5 an Administrator to make most of these changes. Select the settings you want to use for the appearance and
performance of Windows on this computer.
Perfarmance
Wisual effects, processor scheduling. memory usage, and vitual memony (O Let Windows choose what's best For my computer
Adjust for best appearance
—_— Adjust for best performance @ff——
) Custom:
User Profiles [Z1 nimate controls and elements inside windows -

Deskiop settings related ta pour logon

Startup and Recovery

System startup, system fsilure, and debugaing information

Environment Yariables

-
7

Spply

[ Animate windows when minimizing and maximizing
[ Animations in the kaskbar and Start Menu

[ Enable Aero Pesk

[ Enable deskkop composition

[ Enable transparent glass

[ Fade or slide menus into view

[ Fade or slide ToolTips into view

[ Fade out menu items after clicking

[ Save taskbar thumbnail previews

[ Show shadows under mouse pointer

[7] Show shadows under windows

[7] Show thumbnails instead of icons

[7] Show translucent selection rectangls

[7] Show window cankents while dragging

[T slide open combo boxes g
[] Smooth edges of screen Fonts

[ smooth-scroll list bozes -

m

Apply

b
O gl o [ o]
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The “best performance” setting disables Windows Aero themes. earthVision works best
with Aero themes so re-enable your Aero preference.

As a regular user, right-mouse-click the Desktop, pick the Personalize option, then pick
any one of the Aero themes. Back out — save theme if you want — the aero effects are re-
enabled but “best performance” is unaffected.

Every week or two, recheck the performance settings. IT departments and policies have a
bad habit of putting everything back to the Window’s defaults.

Show ALL Files and Extensions

File extensions are hidden by default in Windows. Because Windows’ “idea” of Type
can’t be trusted, showing extensions helps you use the right files for all software.
Example: A folder may have several files with the same name:
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You can’t tell what these files are just from their names. “Type” is often associated with

R [ |
A ‘I + v re .
g st ¥ » Computer » v | 4y ol

Organize « Properties System properties Uninstall or change a program Map network dnve » B w T

sk Drives (2)

Copy

05 (C:) DATADRIVEL (D)
= ey — |
Undo N 645 GB free
Reok with Removable Storage (2)
Select all DVD RW Drive (E:) SJ Triangle TRAVELDRIVE (G:)
- -
il Layout 4 Menu bar W 16GBfreeof 1806

Fol h i -
older and search options v Details pane

| |4 Preview pane pe: 236 GB
NTFS
Rename Navigation pane
hl .
Properties

Close

the wrong program. Not only is this confusing but it’s easy to delete the wrong files. To
show file extensions, click on My Computer to get a window that looks like this:

Under the Organize dropdown Menu, choose Layout and turn on the Menu Bar
Then click the Tools dropdown menu and select Folder Options.

= | =)
@U-v| . » Computer » OS(C:) » JOB » Earth_Vision » Example - |6, || Search Example j e
File Edit View Tools Help
Organize v Include in library = Share with + Burn New folder =~ [0l @&
T Name ° Jate modified vpe Size
' Favorites Name Date medifi Tyt
B Desktop = E| AltonDonut 2/19/201312:27 PM 3D Grid File 2
4« PROJECTS ] AltonDonut AT File
. JOB | AltenDonut Text Dt
1| Recent Places | contours F
& Downloads A contours 2/28/20131231 PM  AutoCAD ShapeS... 12,604 KB
su: contours 2/28/201212:31 PM  AutoCAD Compil... 14 KB
1 | ihrariec h
i 6 items

—_— e ———l
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@Qvf'n » Computer »

v [ 43] [ Search Compute Ll

File Edit View - Help

Organize =

Map network drive...
Disconnect netwo!

_~ Documents

all or change a program

Map networkdrive  » G2 + [T @

% Local Disk Space free: 36.8 GB

&' Music

: DATADRIVEL (D)
k= Pictures = =
B Videos - SV 643 GB free of 931 GB

| 4 Devices with Removable Storage (2) T
‘& Computer g :

K sics & 4 SVD RW Drive (E:) ) Triangle . TRAVELDRIVE (G)
s DATADRIVEL (D) ~ W&}/ 673 MB free of 702 MB S 1.6 GB free of 180 GB .

0S(C) Spaceused: n— | Total size: 236 GB
File system: NTFS

Select the View tab and under Advanced Settings, check:

Show Hidden Files, Folders and Drives then uncheck Hide Empty Drives in the
Computer folder and Hide extensions for known file types and Hide protected
operating system files (answer “yes” when Windows prompts).

Folder Options

General | View | Search
Folder views

Advanced settings:
Files and Folders

f-’: Always show menus

Cidd

You can apply the view (such as Details or lcons) that
you are using for this folder to all folders of this type.

pply to Folders

[T] Always show icons, never thumbnails

[¥] Display file icon on thumbnails

[¥] Display file size information in folder tips

[V] Display the full path in the title bar (Classic theme only)
Hidden files and folders
(") Dont show hidden files, folders, or drives

Show hidden files, folders, and drives

Hide empty drives in the Computer folder

i Hide extensions for known file types

Hide protected operating system files (Recommended) ~ |

| Resstfodes |

m

Restore Defaults

Click OK and now you can see all extensions.
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Appendix B - Installation Problems
(From Pages 23 through 25 of Dynamic Graphics EV Windows Install Guide)

Errors During Installation

An EarthVision installation will install the EarthVision software and, when the “mks”
version is being loaded, the MKS Toolkit as well. Problems can occur in either of these
steps.

EarthVision Installation Problems

The most common problems with the EarthVision installation is lack of disk space. If this
occurs, an error message will appear and the installation must be canceled. More disk
space can be freed, the Trash Emptied on a particular disk, or another disk may be
selected. When more space is available, the installation may be re-started.

MKS Installation Problems

False Error Message

During the installation of the MKS software, an icon may appear on the Task Bar and all
installation activity stops. Click on the icon and the message reports an installation error.
Click “OK” in this box. Another box appears saying that MKS has suffered a Fatal Error
upon installation. Normally this message is not correct and MKS has installed properly.
EarthVision will continue automatically to install. Continue the installation process and
verify that EarthVision is working.

General Error Messages

For most other MKS errors where MKS is not successfully installed, do the following:

= Use the Add/Remove Programs function to remove any MKS or NUTCRACKER
application.

= Remove the “DataFocus” key from the registry:
1. Open regedt32:
Start -> Run -> regedt32

2. Go to:
HKEY LOCAL_MACHINE\SOFTWARE\
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Select the DataFocus key.

Delete the DataFocus key by:
Edit -> Delete

NOTE: Of course caution should be exercised here. We are trying to get rid of all the
DataFocus entries but nothing else.

= In extreme cases, it may even be necessary to remove the NUTROOT
directory manually (usually C:ANUTROOT) after MKS 7.x has been
uninstalled.

= Reboot and try to re-install EarthVision.

File Sharing Problems

One class of MKS installation errors simply reports a Fatal Installation Error but does not
install the MKS software. This can be due to the fact that MKS requires that the “File and
Printer Sharing” service be turned on. To check this, please do the following:

Start -> Settings -> Control Panel -> Network & Dial-up Connections -> Local Area
Connection

On the General tab, select Properties and look for the setting of:
File and Printer Sharing for Microsoft Networks

This service should be checked. If it is not, check it and reboot.

Administrator Privileges

Windows allows other users to have some or all privileges normally reserved for
administrator. Unfortunately, these accounts often do not have full administrator privileges
and this can provoke an error in the MKS installation.

This type of failure to install MKS usually only provides a SEVERE error message stating
that the installation could not be completed.. If this occurs, you should re-do the
installation as the actual “administrator” account.
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Uninstallation Problems

From time to time, the removing of EarthVision from a computer can encounter
problems. Typically, the software is removed but it still exists on the Add/Remove
Programs menu and new software will not install, complaining that the previous version
is still installed. When this occurs, two things are required:

A. Delete the “Dynamic Graphics\” folder (often in C:\Program Files\Dynamic

Graphics)\).
B. Remove a key from the registry. Here are instructions for this removal:

Start up the registry editor: Start -> Run -> regedit

Navigate to:

HKEY LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstal
I

From the table below, note the GUID of the previous version. In regedit, find and
select the key with that GUID. Delete the key: Edit and Delete.

Product \Version |Bit GUID

EarthVision [8.0 32/64-bit  {1B0999A5-F741-47E7-98BD-B245B5762D22}
EarthVision [8.1 32/64-bit  {F4848228-0B28-4594-A63D-B9F6C3D54347}
EarthVision [8.2 32-bit {31B44257-DF75-4DBA-A616-53203C5299F0}
EarthVision [8.2 64-bit {807575B6-268F-4C5D-B543-7825E6389FDF}

EarthVision 9 32-bit {C16F6EDO0-0827-4354-83EC-263B510E9894}

EarthVision 9 64-bit [FC7F9E98-E6FC-4406-BF53-A47A551E0296}
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